Back to overview
Degraded

Game Panel is down

Jun 30 at 03:02am BST
Affected services
Game Panel

Resolved
Jul 02 at 07:42pm BST

Game Panel recovered.

Created
Jun 30 at 03:02am BST

Game Panel has an ongoing SSL error which could cause connections to be degraded.