Back to overview
Downtime

Website is down

Apr 04 at 03:25am BST
Affected services
Website

Resolved
Apr 04 at 03:27am BST

All systems built successfully and cxmpute.com is now serving traffic as expected.

Created
Apr 04 at 03:25am BST

Our main website is currently being updated and could be unavailable for up to 5 minutes whilst the new deployment is being built.