Back to overview
Downtime

CTRL currently unavailable

Aug 05, 2023 at 10:23pm UTC

Resolved
Aug 05, 2023 at 10:28pm UTC

Our upstream provider has fixed the issue with our services and we're back online!

Created
Aug 05, 2023 at 10:23pm UTC

We're looking into issues causing downtime with CTRL.