Back to overview
Degraded
CTRL - surge in network usage
Jun 19 at 12:23am BST
Resolved
Jun 19 at 11:44pm BST
We believe the problem is now resolved. Please contact us at support@cxmpute.com if you continue to encounter issues.
Affected services
Created
Jun 19 at 12:23am BST
Due to a DoS attack, CTRL is currently running slower than usual. Services and functions continue to run as normal but you may experience delays in use.
Affected services